[NEW MERCENARIES] Please note that all new forum users have to be approved before posting. This process can take up to 24 hours, and we appreciate your patience.

UI Causing Frame Lag and Freezes

Comments

  • JentemoonJentemoon
    Vindictus Rep: 1,755
    Posts: 40
    Nexon
    Hey There everyone~

    I just wanted to pop in here since I've been monitoring this issue here on the forums ( and in our tickets ) The team here in NA knows about this issue and we have informed the Developers about it along with the traction it has gotten here on the forums. They know about it and as far as we know looking to work towards a solution to the UI Lag Issue.

    At this time we do not have an ETA :c I know that this issue is super frustrating, I experience it myself when I play as well. We are taking your reports seriously and reported it as soon as we could to our team. I do apologize for the delay addressing this issue and wish I had a better ETA to give everyone.
    ZezeNoburoFlufffyParrotBladehawkarkaine757Controller001FriedeZeloh
  • FlufffyParrotFlufffyParrot
    Vindictus Rep: 1,055
    Posts: 71
    Member
    edited December 22, 2016
    thank god, thought the devs where never going to do anything about it.
  • NoburoNoburo
    Vindictus Rep: 2,940
    Posts: 329
    Member
    edited February 16, 2017
    Just bumping this because it's still unfixed and the EU forums are now read-only. Their UI lag thread had a lot more staff activity in it and a lot of player hardware reports were condensed into that thread as well, maybe they can repost here should the NA team need more information.

    This is the last post from NXKaas in that thread; it's fairly similar to Jentemoon's response above, so we still don't know much about it apparently:
    6PD3sIv.png

    I may edit the op again now that certain aspects of the issue have been fixed or confirmed unrelated, and we have a somewhat better understanding of when the lag starts to happen.
  • NavNav
    Vindictus Rep: 715
    Posts: 11
    Member
    Ui slows the game since I first time played in 2011, it eats cpu performance no matter what cpu you have, even i5 6600 struggles in 10-20fps sometimes, which is ridiculous.

    There is definitely old not optimized part of code in game UI rendering, maybe some calculations with a lot of memory allocation in cycles.
  • UsagiiiKunUsagiiiKun
    Vindictus Rep: 1,855
    Posts: 62
    Member
    bumpppppppppp kms
  • DangerousHobbitDangerousHobbit
    Vindictus Rep: 630
    Posts: 50
    Member
    Please fix,it makes me quit the game,I can barely move in town and battles with everything on low I have no more than 20fps this is ridiculous.
  • CloakshireCloakshire
    Vindictus Rep: 4,580
    Posts: 646
    Member
    Been 3 months since the last "No ETA on a fix" announcement. Can we get an update? The last post said that the Devs are looking to work on a solution. Maybe let us know if the Dev's started working on that solution? Im not looking for an ETA, just an update.
  • SyklesSykles
    Vindictus Rep: 100
    Posts: 4
    Member
    I mean this is beyond ridiculous. If I double tap Keypad Minus, basically disable the whole UI, I get stable 60 FPS While hosting for 4 people or so, if I have the UI running I am capped at 30 FPS at best and playing with multiple people is borderline impossible, and it seems the issues has been going around for over 3 months, 3 months to solve something simple yet major to improve the quality of the game as a whole.

    Do the devs even care at this point? How can something like this even happen, dont you have QA when it comes to writing garbage code?
  • TheNakedDuckTheNakedDuck
    Vindictus Rep: 510
    Posts: 17
    Member
    Always had lagg and didn't know why but after seeing this post tried to remove the ui and got an amazing increase in fps,the game feels completely diferent.The thing is,as a kai I can't just not use some of the things the ui provides wich sucks...
  • CloakshireCloakshire
    Vindictus Rep: 4,580
    Posts: 646
    Member
    edited March 12, 2017
    There's something i actually just discovered. It would seem that when I log in, I catch about 60fps in colhen with the UI on. BUT when I hide the UI and proceed to call it back, my fps is now way lower. It would seem that the UI bogs down after it's reloaded IE: Turning it off/on, hitting a loading screen. Notice how in the first screenshot, I'm at 60fps. I turn the UI off/on, now I'm down to 45fps.

    K6vJZ2Z.jpg

    EiZHQrJ.jpg
    UsagiiiKunAnthonytonyboy
  • DangerousHobbitDangerousHobbit
    Vindictus Rep: 630
    Posts: 50
    Member

    This is what I noticed while playing the game and when it started to lag even more than it already does,this is a really big issues for me and rather than play this game with so bad fps I rather quit.This is an important issues that gm's should stop ignoring or the game will be dead for good!
  • V0lterixV0lterix
    Vindictus Rep: 1,555
    Posts: 144
    Member
    The GMs are not Devcat. You are also not the first, nor the last person to figure out that the UI causes lag. Nexon NA GMs have made this colossal issue known to Devcat.
  • DangerousHobbitDangerousHobbit
    Vindictus Rep: 630
    Posts: 50
    Member
    edited March 13, 2017
    V0lterix wrote: »
    The GMs are not Devcat. You are also not the first, nor the last person to figure out that the UI causes lag. Nexon NA GMs have made this colossal issue known to Devcat.

    This is good,right?
    Not feeling like playing the game in this state and and i'm definetly not the only one that shares my pain.
  • AimAndKillAimAndKill
    Vindictus Rep: 1,590
    Posts: 127
    Member
    1-Disable Multicore settings, it'll help a lot. And also texture streaming.
    2-Go into task manager - details find blackcipher - right click it - set affinity - uncheck all cores except for one -right click it again - set priority to low - find Vindictus.exe - right click - set priority high.
  • DangerousHobbitDangerousHobbit
    Vindictus Rep: 630
    Posts: 50
    Member
    edited March 13, 2017
    AimAndKill wrote: »
    1-Disable Multicore settings, it'll help a lot. And also texture streaming.
    2-Go into task manager - details find blackcipher - right click it - set affinity - uncheck all cores except for one -right click it again - set priority to low - find Vindictus.exe - right click - set priority high.
    679abda6f2.jpg
    You mean this?Already tried that.
    And always thought those 2 settings helps you with performance,oh well..
    Edit:I did everything you said disabling multicore and texture streaming made no difference but those elevations helped changing the blackcipher settings but now much,when I started the boat and I pressed start game did the same,freezed for a few seconds and dropped my fps from 60 to 20...I think no matter I do it wont solve ti since its a game problem and not a pc problem.
    Also the blackcipher returns to its normal settings when I am in-game for some reason.
    Even tried to end the black cipher process,not helped at all,guess byebye vindictus.
  • UsagiiiKunUsagiiiKun
    Vindictus Rep: 1,855
    Posts: 62
    Member
    having UI turned on has caused minor lag as opposed to UI turned off ever since I can remember, but now more than ever its waaay more noticeable which highkey sucks :U ?
    like sure it's bearable to play the game with UI turned off but then playing Kai or staff Evie is basically torture imo :# :#
  • VladinoVladino
    Vindictus Rep: 2,875
    Posts: 231
    Member
    Nice video. Thumbs up for spending your precious time for making it. Seems like devs don't like testing and now that you stated what causes fps drops they have half the work done. If they are testing on the PCs mentioned in recommended requirements then they have difficult time noticing FPS drop from 1 FPS to 0.7 FPS (maybe I went a little overboard) (https://support-vindictus.nexon.net/hc/en-us/articles/205652675-What-are-the-Minimum-System-Requirements-for-Vindictus-)
  • DangerousHobbitDangerousHobbit
    Vindictus Rep: 630
    Posts: 50
    Member
    Vladino wrote: »
    Nice video. Thumbs up for spending your precious time for making it. Seems like devs don't like testing and now that you stated what causes fps drops they have half the work done. If they are testing on the PCs mentioned in recommended requirements then they have difficult time noticing FPS drop from 1 FPS to 0.7 FPS (maybe I went a little overboard) (https://support-vindictus.nexon.net/hc/en-us/articles/205652675-What-are-the-Minimum-System-Requirements-for-Vindictus-)

    Thanks,I definetly have the requirments to run everything on low at full fps and as you can see I still lag like crazy,I tried everything to not have 20 fps everywhere but nothing worked,the only way si to fix the game.
  • PrototypemindPrototypemind
    Vindictus Rep: 8,530
    Posts: 1,320
    Member
    Pretty common thing. I know in a lot of games it is because of the UI being built off of Flash. Even incredibly minimal UIs like that in Guild Wars 2 is a huge drag on the system, which is funny considering all the effects and movement that are rendered to the screen for the characters and environment. Strangely it doesn't seem to be an issue in a lot of shooters, even those with pretty heavy UIs. Not sure if theirs use something else or they're just better put together, but I know people would be screaming bloody murder in those games if they were lagging like that.
  • MastaMasta
    Vindictus Rep: 840
    Posts: 59
    Member
    AimAndKill wrote: »
    1-Disable Multicore settings, it'll help a lot. And also texture streaming.
    2-Go into task manager - details find blackcipher - right click it - set affinity - uncheck all cores except for one -right click it again - set priority to low - find Vindictus.exe - right click - set priority high

    Does disabling multi-core actually help with fps?