[NEW MERCENARIES] Please note that all new forum users have to be approved before posting. This process can take up to 24 hours, and we appreciate your patience.

Town Loads, but Battles Won't :( Please Help!

Vindictus Rep: 100
Posts: 3
in Tech Support
I'm getting back into the game after a few years away, and I'm finding that I'm not able to load any battles. I can run around in Town and use the Marketplace just fine, but whenever I try to start a Solo Battle, the game will try to load it for barely two seconds and instantly hit me with a "Your connection to the host relay server was unstable and closed as a result." message and take me back to the title screen. Weirdly enough, I sometimes can see the words of the map and my health bar at the top of the screen load in while I'm at the title screen (see picture), but logging in only takes me back to town.

I really don't think it's my internet's issue, because I'm at a major university and I can play all my other online games perfectly fine (League, Overwatch, CSGO, etc.) and without lag. I'm also getting consistent 60 FPS on medium graphic settings. When I try to make a party, the boat will load, but I'm not able to launch it (I just get that "Preparing to load battle" loading message, which never goes away), and when I try to join a party, I get the "Preparing to load battle" loading message stuck in the middle of my screen, but the game never takes me to the actual boat. I've tried launching the game from both the Steam Launcher and the Nexon Launcher, both giving me the same error. Can someone tell me what's going wrong? Thank you!