[NEW MERCENARIES] Please note that all new forum users have to be approved before posting. This process can take up to 24 hours, and we appreciate your patience.

HELP: Framerate/lag with ASUS GL702VM laptop

DragonRiderDragonRider
Vindictus Rep: 2,445
Posts: 429
Member
edited February 5 in Tech Support
I get very bad framerate issues / lag with my ASUS GL702VM. My internet speed is 100 mbps download and 20 mbps up

Does anyone have solutions how i can play this game with better framerate , and less lag? Please help

Comments

  • CloakshireCloakshire
    Vindictus Rep: 3,335
    Posts: 470
    Member
    edited February 8
    I get very bad framerate issues / lag with my ASUS GL702VM. My internet speed is 100 mbps download and 20 mbps up

    Does anyone have solutions how i can play this game with better framerate , and less lag? Please help


    Can you answer the following questions to better help narrow down the possible cause.

    How low is your framerate currently?

    Is it always this low, or does it just drop low in certain situations? IE: in town, specific battles.

    Disregarding the framerate lows, what would you say your average framerate is?

    Is your laptop's power plan set to high performance?

    What are your in-game graphics settings?
  • DragonRiderDragonRider
    Vindictus Rep: 2,445
    Posts: 429
    Member
    the game freezes when approaching vendors at time and npc's (lasting a couple seconds), and sometimes in battle (all battles)

    but the frame rate is high 50 -65.

    laptop's power plan / etc is set to highest performance, and in-game graphics settings are set to max as well.
  • LadyFayeLadyFaye
    Vindictus Rep: 1,090
    Posts: 52
    Member
    edited February 21
    Sounds like your hard drive is busy. Are you still having the issue?